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Getting Started With DO Analyser Software Version 4

1. System Requirements

1.1 Minimum System Requirements

Operating System: Windows 98, 98 SE
Windows ME
Windows NT 4.0 with Service Pack 6A
Windows 2000 with Service Pack 2 or later
Windows XP
Windows Vista

Software: Internet Explorer 5.0 or later
Microsoft DAO 3.6 (Data Access Objects)
Microsoft Jet Engine Version 4.0
Adobe Acrobat Reader 5.0 or later for documentation

Free hard disk space: 10 MB (without data files)
RAM: 64 MB (128 MB with Windows XP)
Screen resolution: 800x600 or higher
Colour depth: 16 Bit or higher
Interfaces: One serial port (optional by using an USB to serial converter)
DO Analyser: Hardware Version 2.2 or later.

1.2 Recommended System Requirements
Operating System: Windows 2000 SP4, Windows XP SP2, Windows Vista
Software: Internet Explorer 6.0 SP1 or 7.0

Microsoft Jet Engine Version 4.0 SP8
RAM: 256 MB (512 MB with Windows XP, 1024 MB with Vista)
Screen resolution: 1024x768 or higher

Microsoft DAO 3.6 and Jet Engine 4.0 are included with Windows 2000 and later. However, update
of the Jet Engine by the newest service pack is highly recommended. For Windows 9x and
Windows NT they must be installed separately. See below for further instruction.

SiS O2plus 1-channel titrators are not supported. This software requires a DOA hardware version
2.2 or later. This applies to all systems since August 1994. Older systems must be send to SiS
GmbH for service and upgrade. Systems which has been serviced after 1994 have already been
upgraded.
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2. Software Installation

2.1 Installation Program
The installation program is distributed on CD and for download in two versions:

● A Set-up (full) version containing all files,
● An Update version containing only changed and new files. The update version requires an

already installed version and is usually only available on the SiS web site at
http://www.sis-germany.com/download.htm#doa.

With Windows NT or later, the set-up program must be run with administrative or power user
privileges. If the set-up program is executed with insufficient privileges it will terminate with an
error message. When installing an update, it must be performed as administrator or the same
(power) user that has installed the DOA software the first time.

2.2. Installation Progress
To start installation, execute the set-up or update program. When having an installation CD, the set-
up program will be started automatically when inserting the CD, provided that the Windows auto
start feature is enabled. In all other cases use the Windows Explorer to navigate to the location of
the set-up or update program and start it by double-click.

2.2.1 Language
Select your language (Dansk, Deutsch, English, Francaise, Nederlands, or Espanol). This selection
does not specify the language of the DOA program (currently only available in English), but the
language used by the Set-up program itself and the language of the start menu entries. Additionally,
when selecting 'Deutsch', some German documentation is installed. If the local system does not use
code page 1252 only 'English' is available. See also section 4. 'Localization'.

2.2.2 Welcome Screen
Displays the name (DOA) and version of the software.

2.2.3 Information
Displays the contents of the INSTALL.TXT file (detailed installation notes).

2.2.3 Select Destination Location
Select the folder where the software should be installed. Default is 'C:\Program Files\Doa' (for
English Windows versions; with other languages program folder may have a different name). This
page is not displayed with the update package.

2.2.4 Select Components
Select the components you want to install.
Default: Install all files except the DOS version
Full: Install all files
Compact: Install only program and help files
Custom: Select components manually

Note:
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When choosing the DOS version component, the DOS files are copied to the sub folder 'dos'
in the destination location. The DOS version itself must be also installed before it can be
used. This can be done manually after this set-up, or by checking the appropriate check box
on the 'Additional Tasks' screen (see below). See the README.TXT in the dos folder for
installation instructions.

2.2.5 Select Start Menu Folder
Select a folder name where short cuts are stored. Check the "Don't create a start menu folder" check
box if you did not want to create a folder with short cuts. Default folder name is 'Doa'. This page is
not displayed with the update package.

2.2.6 Select Additional Tasks
● Create a desktop icon for all users.
● Create a quick launch icon (Windows 9x/ME only).
● Associate files. Double-click on DOA database files loads the file with the DOA application.
● Create data directory. Creates a directory for DOA database files inside the common

application data folder. A typical path is 'C:\Documents and Settings\All Users\Application
Data\Doa'. It is recommended to use this or another global accessible folder to store the data
files on multi user systems.

● Run the DOS version installation program (only for Windows 9x/ME and if DOS version
component selected).

2.2.7 Check for Required Database Support
The Set-up Program will check if database support is installed on your system. If files are not
installed or too old they must be installed or updated. See the file MDAC_ENU.TXT and section 5
'Installing Microsoft DAO and Jet Engine' for more information.

2.2.8 Ready to Install
Displays the current settings. Choose 'Install' to start the Installation or go back to change settings.

2.2.9 After Install
Additional options.

● View DOS version install instructions (Win 9x only if component selected) View the
README.TXT file for the DOS version.

● Install DOS version (Win 9x only if component selected) Launches the install program of
the DOS version.

● View the DOA README file
● View the MDAC README file
● Launch DOA software

3. Localization
The DOA software currently supports English language only. However, the program uses some
localized Windows system files generating messages in the language of the installed Windows
version. The text of start menu entries and desktop icons created during set-up depends on the
language selected during set-up.

4. Uninstall
On Windows NT and later, uninstall can be only performed as local administrator.
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There are three ways to uninstall the DOA software:
● Use the 'Uninstall' option in the DOA start menu folder, or
● select DOA from the Add/Remove Programs list in the control panel, or
● launch the unins000.exe program in the DOA program folder

Uninstall will only remove files that have been copied during install. Files created by the program
or copied manually to the DOA folders will be left in place.

Shared system files installed or updated during installation are not removed.

If the DOS version has been installed it is not removed by the uninstall program. To uninstall the
DOS version simply remove the directory containing the DOS software.

5. Installing Microsoft DAO and Jet Engine
All files are language dependent. Therefore, you have to download the specific versions for your
Windows version and language. See the file MDAC_ENU.TXT for further information. This file is
copied to the program directory during install. If these components are not present (with Windows
9x and NT 4), the DOA software will terminate with an error message.

6. Files That will be Installed
Components Path File(s) Description
all PF Doa.exe Main program
all PF Doa.chm Help file
all PF Db-template.doa Database template file
all PF INSTALL.TXT Installation notes
all PF HISTORY.TXT Change log
all PF README.TXT Additional information
all PF MDAC_ENU.TXT Data Access Files installation notes
all PF Getting_Started.pdf This document
all PF Unicows.dll Unicode support for Win 9x, Win 9x only
all PF Gdiplus.dll Graphics Device Interfaces Library, Win 9x, NT,

2000 only
all - - Folder is created optionally
all* SYS Shfolder.dll Shell Folder Library, Win 9x only
all* SYS COMCTL32.DLL Common Controls Library, Win 9x only
doc PF\doc *.pdf Documentation
dos PF\dos *.* DOA 3 DOS version install files

All* = Installed if not already present or an older version
CA = Common application data folder. A typical path is

C:\Documents and Settings\All Users\Application Data
PF = Program folder (destination location selected during set-up)
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SYS = Windows system folder

7. Using the Software the First Time
The information of this sentence is nearly identical to the "Getting Started" section of the DOA help
file.

7.1 DOA Software Differences to Other Applications
The DOA software uses database files for storage. Therefore, some menu commands behave
differently or do not exist as with applications using normal files. This applies especially to the File
and Edit menus. The differences will be explained in detail later.

7.2 The Operator
All record sets stored in the database have a field called 'Operator'. Before any data can be saved,
you must create operators. The intended use of this field is to know about the person who has
performed titration and created or edited data. Even if there is only one person working with the
analyser, or you don't want to use this feature, you must create at least one operator. This is
discussed in this place, because you should decide now if you want to use this feature or not. If all
users working with this software use their own Windows login accounts, we recommend to use the
System User option which can be selected in the configuration (see next sentence). We also
recommend to use this option if there is only person working with the analyser. When it is active,
you do not have to select yourself as operator when opening an existing DOA database file.

7.3 Configuration
When starting the program the first time, you should go to the Configuration in the Options menu.
For the first time it may be only necessary to select the serial port which is connected to your DO
Analyser.

If you decided to use the System User option, check the appropriate check box in the Database Tab
and optionally the check box to add users automatically.

To get help about the configuration options, just press F1 or activate the Help button when in the
configuration dialog.

NOTE: 
The configuration settings are stored independently for each Windows user. If there are multiple
users working with this software, each one has to set the configuration options.

7.4 Testing the Connection to DOA
After configuring the serial port you should check the communication with your DO Analyser.
Power the analyser and select the Test command from the Options menu. In case of problems
consult the hardware section of the troubleshooting page in the help file.

7.5 Creating a New Database File
Select New from the File menu or click on the New button in the tool bar (the left most tool bar
button showing a white piece of paper). The Create New DOA database dialog is opened. The
optional data import options are not of interest now; import may be also done later. There is an Add
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me ... check box. Availability and pre-set may be (tested in this order):

Name Available Checked System
User
Option

Remarks

System user No Yes Yes Adds system user.
Current operator Yes Yes No Only if there is a database file open with an

selected operator. Uncheck if you don't want
the current operator to be added.

System user Yes No No Suggested name, must be checked manually.
(None) No No No No adding possible.

Enter a file name for the new file (optional use the Browse button to select a different path) and
select OK. If the Add me ... option is not active, the Select Operator dialog is displayed. You should
read the next section even if the option is active. It contains some useful information.

7.6 Selecting and Adding Operators
The displayed list is empty because the newly created database contains no data. So you should use
the Add button to create one or more new operator record sets. You may also discard the dialog
without adding any record sets. This dialog can be activated at any time with the Change User
command from the File menu or the corresponding button in the tool bar (showing a persons head).
The Add commands opens the New Operator dialog box which contains three fields:

Field Description
Name Enter the operator's name. This name must not be empty and has to be unique among

all existing operator names.
Comment Optionally enter a comment.
Active This option must be checked to allow selection of the operator. Its intended use is to

exclude operators from selection when they no longer work with the analyser; e.g.
when they left your organization or department.

7.6.1 Automatically Added Operators
Operators are added automatically when the Add me ... check box in the Create New DOA database
dialog is checked. The comment field of these operators is set to 'System user (automatically
added)' and the active field is checked.

7.6.2 Adding Operators From List of Operators
Operators can be also added with the Add command of the Edit menu when in the list of operators.
Additional information follows in the The Database menu section.

7.7 Saving, Closing, and Opening DOA Database Files

7.7.1 Saving Files
You may have noticed that there is no Save command in the file menu. It's not necessary. Database
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files are saved automatically when there are any modifications.

7.7.2 Closing Files
You may have noticed that there is no Close command in the file menu. It's not necessary. Database
files are closed automatically when:

● Terminating the DOA program
● Opening an existing file
● Creating and opening a new file
● Closing all program sub windows

So close all windows (there should be only the log window open), by clicking on the close button
(X) on the top right corner. You may also press Ctrl-F4 to close sub windows.  Alternatively,
terminate the program with the Exit command from the File menu, the close button of the main
window, the close option of the control menu (click on the DOA logo on the top left corner of the
main window to open the control menu), by double clicking the control menu button, or by pressing
Alt-F4.

7.7.3 Opening Files
There are three to four ways to open files:

● With the Open command of the File menu
● With the Open button in the tool bar (those showing a yellow open folder)
● From the Recent File list of the File menu.
● Automatically open the most recent file at program start when the corresponding option in

the configuration is set

So choose one way to open the just created new file. If the System User option is not active, the
Select Operator dialog box is displayed again. In this case, select yourself as operator.

7.8 The Database Menu
The Database menu provides access to all data tables stored in the database. The menu has two
sections:

● Basic data. These must be entered manually or imported.
● Titration data. These are created by performing titration.

Each of the data options opens a view window containing a list of the selected type. There may be
multiple views opened at the same time. Select the Operators command now to open the list view
of operators. We will use this list to explain how to use the list views.

7.8.1 Database List Views
The list view itself contains three areas (one may be disabled):

● The filter area
● The list header
● The list itself

7.8.1.1 List Filter
The filters are displayed by default but may be shown or hidden with the Filter command of the
View menu. The filters allow reducing the amount of data displayed in the list. Number and types of
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filters depend on the type of list. The operators list contains only two filters: Available and Date.
Detailed information on filtering can be found on the Filter page in the help file.

7.8.1.2 List Header
The list header contains the column labels and can be used to sort and format the list. Please refer to
the List Header page in the help file for detailed information on sorting and formatting the list.

7.8.1.3 List
The list contains the record sets of the specific type. You may notice that the operators list contains
one more operator named 'Imported' and one more column than input fields when creating an
operator record set. The 'Imported' operator is a predefined record set used for data import. The
Date column contains the date of creation. This field exists in all tables and is set automatically
upon creation. And what about the time of creation? Click right on the list header and select the
Columns - Time option to display also the time column.

List actions can be performed by using the commands from the Edit menu and with the context
menu (right click inside the list). The availability of commands depends on the current selection of
record sets. To select record sets use the cursor keys or the mouse. Use together with the Shift key to
select a block of sets or the Ctrl key to select multiple individual record sets.

Available commands are:

Command Selection Description
Add - Create a new record set.
Add Copy 1 Create a copy of a record set. Like Add but pre-set fields with values

from the selected record set.
Edit/View 1 Edit all fields of a single record set.
Edit/View > 1 Edit specific fields of multiple record sets.
Delete ≥ 1 Delete the selected record sets.
Copy ≥ 1 Copy the content of the selected record sets to the clipboard.
Copy All - Copy the content of all record sets to the clipboard.
Copy Cell - Copy the content of the clicked cell to the clipboard.
Select All - Select all record sets.
Deselect ≥ 1 Deselect record sets.

Some of these commands differ from those found in other, non-database, applications.

Please refer to the List Context menu and the Edit menu pages in the help file for detailed
information on the list commands.

To become familiar with the list commands, you should now use them.

7.9 Required Data for Titration
Before any kind of titration can be performed, you must enter data to the tables. Please use this
order, because some tables depend on others:
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Table Required for Remarks
Operators creating record sets in other tables
Exchange Units titers, all kind of titration
Dispensers all kind of titration
Titer all kind of titration
Standard Solution standard and blank titration
Bottle Groups bottles, sample titration
Bottles sample titration
Samplers sample titration The database already contains a

predefined record set.
Parameter all kind of titration The database already contains a

predefined record set.
Reagents (Acid,
Iodide, MnCl2)

no other tables The database already contains a
predefined record set.

If you are upgrading from the DOS software, you should now import your existing data. After
import open each table to check and optional edit the imported data and optional add some new
data.

Otherwise open each table and add at least one record set. Press F1 when on the new record set
dialog to get help about the input fields.

7.9.1 Add Operators
You already have at least one record set. Optionally add some of your colleagues.

7.9.2 Add Exchange Units
Add all of your exchange units used with the DO Analyser.

7.9.3 Add Dispensers
Add all of your dispensers used with the DO Analyser. There must be at least one dispenser for each
kind of reagent.

7.9.4 Add Titers
Add all of your prepared titers.

7.9.5 Add Standard Solution
Add all of your prepared standard solutions.

7.9.6 Add Bottle Groups
Bottle groups are provided to allow usage of different bottle sets. If you do not have multiple groups
of bottles, you must add at least one group. Simply name it 'Default Group'.
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7.9.7 Add Bottles
This is the most lavish activity. Please note that all bottles belonging to the same group must have
different names.

7.9.8 Add Samplers
Samplers are optional. However, there must be at least one entry in this table. If you don't want to
track information about samplers, you may use the provided default set named 'No sampler'.

7.9.9 Add Parameter
Optional add a new parameter set or change the provided default set.

7.9.10 Add Reagents (Optional)
Optional add data for your reagents (iodide, MnCl2, and acid). When not doing so, the predefined
record sets are used.

7.10 Performing the First Titration
To become familiar with the DOA software we recommend to use the demo mode at this point. In
demo mode, the titration process is simulated and runs about ten time times faster than real titration.
To start in demo mode use the DOA Demo option from the DOA group in the start menu which has
been created during installation. You may also use the command line options '-d', '-D', or '--demo' to
start in demo mode.

7.10.1 Standard Determination
Before a sample titration can be performed, each titer must be standardized. To start a standard
determination choose Standard from the Titration menu, or use the Add command when the
Standardizations list view is the active window. Please use the specific help on all dialogs that
appear during and after standard determination.

7.10.2 Blank Determination
Blank determinations are optional. They are not required (the database contains a not visible
predefined blank record set with a blank value of zero). If you want to perform a blank
determination, just choose the Blank option from the Titration menu.

7.10.3 Sample Titration
Now you are ready to perform the first sample titration.

8. Upgrading from the DOA 3 DOS Software
You should read this only  if you are upgrading from the DOS software or used the DOS software in
the past.

8.1 What Has Been Changed?
The windows software has a lot of modifications and enhancements.

8.1.1 Data Storage
The DOS software stores data in three kind of files: Bottles, configuration, and titration result. The
Windows software uses only one kind of files: Database files holding all titration results and base
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data like bottles and exchange units. These database files may be shared by multiple users. The
general program configuration is stored separately in the Windows registry for each user.

8.1.2 Post Processing
The DOS software did not allow post processing of data (e.g. changing the bottle number, or
entering the salinity after titration has been performed). The Windows software allows changing of
nearly any values. However, some fixed values may not be changed (e.g. time stamps, titer amount
of titration). To avoid loss of important data, changed values will not overwrite the original (first
entered) data, but be stored in separate places.

8.1.3 Configuration
Some of the configuration options have been moved to the database:

8.1.3.1 Exchange Unit Volume and Fill Speed
The Windows software supports multiple exchange units. Therefore, the volume and fill speed has
to be specified in the Exchange Unit table.

8.1.3.2 Titration Parameter
The Windows software supports multiple parameter settings. Therefore, the settings have to be
specified in the Parameter table. This allows different settings for different types of titration like:

● Settings for standard determinations (clear water, high concentration)
● Settings for blank determinations (clear water, low concentration)
● Settings for turbid sample
● Settings for low concentration samples

8.2 Importing Data from the DOA 3 Software
There is an import option to read data stored in DOA 3 data files. These kind of data may be
imported:

● Bottles
● Exchange unit (volume from last standardization)
● Standard dispenser (volume from last standardization)
● Reagent dispenser (volume from last sample titration)
● Recently used titer
● Recently used standard solution
● Recent standardization
● Recent blank determination
● Titration parameter

8.3 Other Enhancements
● The calibration program is now part of the software and no longer a stand-alone program.
● Data can be exported in various formats (Text, HTML, CSV, Excel).
● Support for USB to serial converters.
● Supports KIO3 and KH(IO3)2 as standard solution reagent.
● Supports normality and weight input for standard solution concentration.
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9. Further Information
The help file of the DOA software contains all necessary information. It can be accessed from
within the DOA software or by an entry in the DOA group in the start menu which is created during
install.

Besides the help file, there are some text files containing up-to-date information. These files are
copied to the program directory during installation:

README.TXT
General readme file (English).

INSTALL.TXT
Detailed installation notes (English).

INST_DE.TXT
Detailed installation notes (German).

HISTORY.TXT
Change log

MDAC_ENU.TXT
Data Access Files installation notes (English)

MDAC_DEU.TXT
Data Access Files installation notes (German)

SiS Sensoren Instrumente Systeme GmbH
Muehlenkoppel 12
D-24222 Schwentinental
Germany
Tel: +431-79972-0
Fax: +431-79972-11
Email: info@sis-germany.com
WWW: http://www.sis-germany.com
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